AP Essentials - Email Service Disruption

Incident Report for Tungsten Automation APAC

Postmortem

Overview
On February 27, 2026, the AP Essentials email processing service experienced a disruption affecting both inbound and
outbound emails. Inbound invoice emails were not processed, and outbound notifications (such as password resets and RFI
emails) were not delivered. The issue was caused by degraded connectivity between application components and the
production email service within the US environment. As a result, a backlog of emails accumulated prior to resolution.

Incident Detail

  • 08:00 UTC (Feb 27) – Issue escalated to Tungsten Cloud Services
  • 08:22 UTC – Status page updated to Investigating across all regions
  • 10:07 UTC – Root cause identified: connectivity degradation between application and email service
  • 10:23 UTC – Corrective actions implemented
  • 10:42 UTC – Connectivity restored; backlog processing resumed
  • 11:44 UTC – Email queues fully drained
  • 12:10 UTC – All queues confirmed at normal levels; status updated to Resolved

Resolution
The connectivity issue between the application and email service was identified and remediated, restoring normal
processing. Email queues were processed in a controlled manner until the backlog was cleared. Full service restoration was
confirmed at 12:10 UTC on February 27.

Root cause:
The incident was caused by connectivity degradation between application servers and the production email service in the US
environment, which rendered the email processing service temporarily unresponsive.

Improvement actions:

  • Replacement of the legacy email processing component with a modern, cloud-native service is underway
  • Improvements of centralised logging and automated alerting for the email processing service to enable proactive
    detection of failures
  • Adjustment in the standard operating procedure and change management controls for email processing service
    failures to ensure faster response times.
Posted Mar 03, 2026 - 00:28 AEDT

Resolved

The incident has been resolved - email-based document processing is functioning as expected.
Posted Feb 27, 2026 - 23:06 AEDT

Monitoring

Corrective measures have been implemented and we are monitoring the results
Posted Feb 27, 2026 - 22:20 AEDT

Identified

The issue has been identified and we are working on a fix.
Posted Feb 27, 2026 - 20:02 AEDT

Investigating

We are currently investigating an issue affecting email-based document processing. Some users may experience delays or failures with inbound and outbound email functionality. We will provide further updates as the investigation progresses.
Posted Feb 27, 2026 - 19:23 AEDT
This incident affected: AP Essentials.